Составить программу,выводящую ** экран слово "Ясно" , если видимое значение давления...

0 голосов
28 просмотров

Составить программу,выводящую на экран слово "Ясно" , если видимое значение давления больше 760 мм.р.ст. и слово "Пасмурно" ,если давление меньше 760 мм.р.ст. (модель барометра)


Информатика (49 баллов) | 28 просмотров
Дано ответов: 2
0 голосов

var P:integer;

begin

writeln ('Введите значение давления');

readln (P);

if (P>760) then writeln ('Ясно')

else

writeln ('Пасмурно');

end.

(666 баллов)
0 голосов

Способ 1: Пользователь сам задает значение 

program sp1;

var i:integer;

begin

readln(i);

if i>760 then writeln('ЯСНО') else  writeln('Пасмурно');

end.

 

Способ номер 2: программа сама придумывает давление.

program sp2;

var i:integer;

begin

randomize;

while (i<700)  do </p>

i:=Random(800);

Writeln('Программа придумала давление',i);

if i>760 then writeln('ЯСНО') else  writeln('Пасмурно');

end.

(60 баллов)