C++Напишите программу, которая заполняет массив из N элементов случайными целыми числами...

0 голосов
149 просмотров

C++Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет количество трёхзначных чисел в этом массиве, которые не делятся на 5.
Входная строка содержит три числа: границы диапазона случайных чисел A и B , а также размер массива N . Все числа разделены пробелами. Гарантируется, что 0 < N ≤ 10000 .
В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке – количество трёхзначных чисел в массиве, которые не делятся на 5.


Информатика (73 баллов) | 149 просмотров
Дан 1 ответ
0 голосов

GNU GCC.

#include
#include
#include
using namespace std;

int main()
{
int a, b, n;
cout <<"Введите границы диапазона и размер массива:" <<endl;<br> cin >>a >>b >>n;
if(n>10000) n=10000;
vector v(n);
srand(time(0));
cout <<"Исходный массив:" <<endl;<br> for(int i=0; i {
v[i] = rand()%(b-a+1) + a;
cout <<v[i] <<" ";<br> }
cout <<"\n3х-значные элементы, не кратные 5:" <<endl;<br>
for (int i=0; i if ((v[i]>99) && (v[i]<1000) && (v[i]%5!=0))<br> cout <<v[i] <<" ";<br> cout <<endl;<br>
return 0;
}

(1.7k баллов)