Информатика.Паскаль.Дано натуральное число N. Составить программу, которая определяет,...

0 голосов
30 просмотров

Информатика.Паскаль.Дано натуральное число N. Составить программу, которая определяет, сколько цифр этого числа кратны трем. P.S т.е мало того что нам нужно определить кратность каждой цифры этого числа ина выходе получит сколько этих чисел.


Информатика | 30 просмотров
Дан 1 ответ
0 голосов

var

  N, count:integer;

begin

   write('N = ');

  readln(N);

  count := 0;

  while N > 0 do

  begin

    if (N mod 10) mod 3 = 0 then

      count := count + 1;

    N := N div 10;

  end;

  writeln('Count = ', count);

  readln;

end.

(3.1k баллов)