С++ Напишите программу, которая выводит номера элементов массива, равных заданному...

0 голосов
238 просмотров

С++ Напишите программу, которая выводит номера элементов массива, равных заданному значению X .

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. В третьей строке записано число X . Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одной строке номера элементов массива, равных X , разделив их пробелами. Предполагается, что нумерация начинается с единицы. Если таких элементов нет, нужно вывести число -1.


Информатика (73 баллов) | 238 просмотров
Дан 1 ответ
0 голосов

#include#includeusing namespace std;int main(){int n,i,j=0,k;cin>>n; int a[n];for(i=0;i>a[i];}int X; cin>>X;int W[n];for(i=0;i<n;i++){ if(a[i]==X) { W[j]=i; j++; }  }for(i=0;i<j;i++)cout<<W[i]<<" ";}

(54 баллов)