Напишите программу которая вычисляет сумму первых n натуральных чисел через оператор while

0 голосов
97 просмотров

Напишите программу которая вычисляет сумму первых n натуральных чисел через оператор while


Информатика (18 баллов) | 97 просмотров
Дано ответов: 2
0 голосов

Var
  n,c:integer;
Begin
  Write('Введите число ');
  Readln(n);
  Write('Сумма чисел от 1 до ',n,' равна ');
  While n<>0 do Begin
    c:=c+n;
    n:=n-1;
  End;
  Write(c);
End.

(2.6k баллов)
0 голосов

Var s,i,n:integer;

begin
  readln(n);


//цикл while
  s:=0;
  i:=0;
  while i     i:=i+1;
     s:=s+i;
  end;
writeln(s);
end.

(13.9k баллов)