Помогите пожалуйста с 13 задачей (напишите программу,не используя power) огромное спасибо...

0 голосов
61 просмотров

Помогите пожалуйста с 13 задачей (напишите программу,не используя power)
огромное спасибо (Pascal ABC )


image

Информатика (54 баллов) | 61 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Сумму членов предложенного ряда можно записать в следующем виде:
\displaystyle S=1+\sum_{i=1}^n(-1)^i \frac{x^{2i}}{(2i)!}=1+\sum_{i=1}^nz_iE_i \\ z_i= \left \{ {{-1, \quad i=1} \atop {-(z_{i-1}), \quad i\ \textgreater \ 1}} \right. \\ E_i= \frac{x^2}{2i(2i-1)} \times E_{i-1}, \quad i\in\mathbb N

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  var x:=ReadReal('x=');
  var n:=ReadInteger('n=');
  var s:=1.0;
  var e:=1.0;
  var z:=-1;
  for var i:=1 to n do begin
    e:=e*x*x/(2*i*(2*i-1));
    s:=s+z*e; z:=-z
    end;
  Writeln(s)
end.

Тестовое решение:
x= 0.45
n= 20
0.900447102352677

Для сравнения cos(0.45)≈0.90044710235267692166884061148
С учетом округления последнего разряда все выведенные знаки верны.



(142k баллов)
0

Мб напишешь мне в лс и скинешь фотки программы в Pascal ABC?

0

"Фотки" в ЛС не прикрепляются.

0

вк

0

Вы обвиняете меня в том, что решение фальшивое? Нет меня ни в каких ВК. Могу на почту скинуть, если в ЛС напишете адрес

0

программа не работает

0

проверила

0

Что пишет?

0

Текст сообщения приведите

0

И, главное, Вы обратили внимание на первую строку в программе: // PascalABC.NET 3.1, сборка 1174 от 22.02.2016

0

Вы в какой среде запускаете программу?