Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа....

0 голосов
118 просмотров

Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа. паскаль


Информатика (55 баллов) | 118 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
  n, s: integer;

begin
  write('Число: ');
  readln(n);
  s := 0;
  while n > 0 do
  begin
    s := s + n mod 10;
    n := n div 10
  end;
  writeln('Сумма цифр = ', s);
end.

Тестовое решение:
Число: 12345
Сумма цифр = 15

(13.9k баллов)
0 голосов

На Java
http://pastebin.com/SbfSZLFK

ввод - 1234567890123456
вывод - 66

var n, sum: integer;
begin
readln(n);
sum := 0;
while n > 0 do begin
sum := sum + n mod 10;
n := n div 10
end;
writeln(sum);
end.

(3.4k баллов)