Написать программу для паскаля: Массив А, состоящий из 10 целых элементов задан через...

0 голосов
33 просмотров

Написать программу для паскаля:
Массив А, состоящий из 10 целых элементов задан через random. Все элементы массива разделить на 2 элемент. Вывести на экран старый и новый массив.


Информатика (65 баллов) | 33 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET v3.1 сборка 1172

Const
 n=10;

Var
 ar:array[1..n] of real;
 i:integer;
 k:real;
begin
randomize;
 writeln('First array:');
 for i:=1 to n do
  begin
   ar[i]:=random(100);
   write(ar[i]:4);
  end;
 k:=ar[2];
 for i:=1 to n do
  ar[i]:=ar[i]/k;
 writeln;
 writeln('Final array:');
 for i:=1 to n do
  writeln(ar[i]);
end.

(38.6k баллов)