Написать программу, которая просит ввести 10 целых чисел и считает сколько из них...

0 голосов
53 просмотров

Написать программу, которая просит ввести 10 целых чисел и считает сколько из них положительный, отрицательно и нулей


Информатика (42 баллов) | 53 просмотров
Дан 1 ответ
0 голосов

Var a,n1,n2,n3,i:integer;
begin
  for i:=1 to 10 do begin
    write('Введите ',i, ' число ');
    readln(a);
    if a = 0 then n1:=n1+1 else
      if a<0 then n2:=n2+1 else n3:=n3+1;<br>   end;
   writeln('Равных 0 : ',n1);
   writeln('Меньше 0 : ',n2);
   writeln('Больше 0 : ',n3);
 end.
  

(13.9k баллов)