Написать программу по предложенной блок-схеме ** C++

0 голосов
31 просмотров

Написать программу по предложенной блок-схеме на C++


image

Информатика (15 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var s,i,a:integer;
begin
s:=1; i:=5;
while s>=20 do
 begin
 a:=i;
 s:=s+a;
 i:=i+5;
 end;
writeln('I = ',i);
end.

Результат:
I = 5
Вот на C++
#include
using namespace std;
int main() {
int s=1;
int i=5;
int a;
while (s>=20)  

a=i; 
s=s+a; 
i=i+5; 

cout << i;<br>}
Но результат всё равно = 5 :)

(194k баллов)
0

Просят на С++, сижу и вспоминаю ...

0

О!!! Прошу прощения! Как-то выпало из поля зрения

0

Сейчас исправлю

0

Спасибо :3 Выручили!

0

Пожалуйста.