Нужно написать программу. Заранее спасибо!!!

0 голосов
43 просмотров

Нужно написать программу. Заранее спасибо!!!


image

Информатика (55 баллов) | 43 просмотров
0

какой язык?

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
  var m:=ReadInteger('M=');
  var a:=MatrixRandom(m,m,1,9);
  for var i:=0 to m-1 do begin
    for var j:=0 to m-1 do Print(a[i,j]);
    Writeln
    end;
  var si:=0;
  for var i:=0 to m-1 do begin
    var sj:=0;
    for var j:=0 to m-1 do sj+=sqr(a[i,j]);
    si+=sj
    end;
  Writeln('S=',sqrt(si))
end.

Тестовое решение:
M= 6
6 5 2 7 1 1
8 7 9 3 1 8
2 1 7 9 5 7
3 2 8 1 1 8
3 9 1 2 6 7
5 3 5 4 8 3
S=32.6190128606002

(142k баллов)
0

println для матриц ведь тоже работает

0

Во-первых, не помню, но по-моему нет, только write. А во-вторых, в любом варианте он не выводит матрицу матрицей, а все в строку.

0

Вообще, у разработчиков желание сделать свой класс для матриц, но это в будущем.

0

вроде можно и собственных экстенженов понаделать, правда у меня не получается(

0

Я написал себе кое-что для работы с матрицами, но нельзя же тут приводить основанное на этом решение.

0

так выложить все вместе и модули(или как их там) и решение

0

Смысл? Выкладывать код, в разы превышающий объем этого решения?