Написать программу формирования массива из 15 целых чисел от 0 до 50 и вывод массива **...

0 голосов
37 просмотров

Написать программу формирования массива из 15 целых чисел от 0 до 50 и вывод массива на экран.


Информатика (12 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

program picaso; uses crt;
type vector=array[1..100] of integer;
var a:vector;
    i:byte;
begin clrscr;
    for i:=1 to 15 do
        a[i]:=Random(50);

    for i:=1 to 15 do
        write(a[i],' ');
end.

 

 

универсальный метод из скольки чисел хочешь (n это номер чисел)

 

program picaso; uses crt;
type vector=array[1..100] of integer;
var a:vector;
    i,n:byte;
begin clrscr;
    writeln('n:');readln(n);
    for i:=1 to n do
        a[i]:=Random(50);

    for i:=1 to n do
        write(a[i],' ');
end.

(102 баллов)