В Паскале (Pascal ABC) выдает ошибку "Нельзя преобразовать тип real к типу integer". как...

0 голосов
218 просмотров

В Паскале (Pascal ABC) выдает ошибку "Нельзя преобразовать тип real к типу integer". как исправить? По заданию нужно написать программу, которая определяет, принадлежит ли точка с координатами (х,у) треугольнику с вершинами в точках с координатами (х1,у1), (х2,у2), (х3,у3). программа:
program _1;
var x,y,x1,y1,x2,y2,x3,y3:real;
begin
write('Введите координаты точки(х,у)'); read(x,y);
write('Введите координаты первой вершины треугольника(х1,у1)'); read(x1,y1);
write('Введите координаты второй вершины треугольника(х2,у2)'); read(x2,y2);
write('Введите координаты третьей вершины треугольника(х3,у3)'); read(x3,y3);
if ((x-x2)/(x2-x1)-(y-y2)/(y2-y1))<=0 and ((x-x3)/(x3-x2)-(y-y3)/(y3-y2))<=0 and ((x-x3)/(x3-x1)-(y-y3)/(y3-y1))>=0
then writeln('Точка с введенными вами координатами принадлежит треугольнику') else writeln('Точка с введенными вами координатами не принадлежит треугольнику');
end.


Информатика (50 баллов) | 218 просмотров
0

и точка при этом может иметь дробное значение?

Дано ответов: 2
0 голосов

Скобки добавьте
(((x-x2)/(x2-x1)-(y-y2)/(y2-y1))<=0)<br>
and (((x-x3)/(x3-x2)-(y-y3)/(y3-y2))<=0)<br>
and (((x-x3)/(x3-x1)-(y-y3)/(y3-y1))>=0)


(9.7k баллов)
0

Кстати, алгоритм не рабочий при вводе координат точки (-1,0) и координат вершин (-1,-3) (-3,2) (4,3) программа выдает, что точка не принадлежит треугольнику, а на самом деле - принадлежит.

0

Да, я тоже проверил. Ошибочка в алгоритме

0

Через любые две вершины треугольника проводим прямую и определяем, лежат ли в одной полуплоскости третья вершина и заданная точка, если лежат, то точка внутри треугольника, иначе - нет.

0 голосов

В строке с условиями не хватает скобок. Вот рабочий вариант вашей программы:
program _1;

var
  x, y, x1, y1, x2, y2, x3, y3: real;

begin
  write('Введите координаты точки(х,у)');read(x, y);
  write('Введите координаты первой вершины треугольника(х1,у1)');
  read(x1, y1);
  write('Введите координаты второй вершины треугольника(х2,у2)');
  read(x2, y2);
  write('Введите координаты третьей вершины треугольника(х3,у3)');
  read(x3, y3);
  if (((x - x2) / (x2 - x1) - (y - y2) / (y2 - y1)) <= 0) and (((x - x3) / (x3 - x2) - (y - y3) / (y3 - y2)) <= 0) and (((x - x3) / (x3 - x1) - (y - y3) / (y3 - y1)) >= 0)
    then writeln('Точка с введенными вами координатами принадлежит треугольнику') else writeln('Точка с введенными вами координатами не принадлежит треугольнику');
end.

Тестовое решение:
Введите координаты точки(х,у)5.2 4.7
Введите координаты первой вершины треугольника(х1,у1)1.1 2.1
Введите координаты второй вершины треугольника(х2,у2)8.3 9.1
Введите координаты третьей вершины треугольника(х3,у3)0.1 10.5
Точка с введенными вами координатами не принадлежит треугольнику



(13.9k баллов)