Программирование ** C++ Найдите самый маленький натуральный делитель числа x, отличный от...

0 голосов
176 просмотров

Программирование на C++
Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 <= x <= 30000).<br>
Входные данные
Вводится натуральное число x.

Выходные данные
Выведите наименьший делитель числа x, отличный от 1.


Информатика (35 баллов) | 176 просмотров
Дан 1 ответ
0 голосов

#include
int main() {
int n;
std::cin >> n;
int i = 2;
while (n % i > 0) ++i;
std::cout << i;<br>return 0;
}

(13.3k баллов)