напишите программу, которая вводит с клавиатуры дынные о n лицах (n меньше либо равно...

0 голосов
107 просмотров

напишите программу, которая вводит с клавиатуры дынные о n лицах (n меньше либо равно 50) и выводит на экран фамилии и имена тех, кто родилсяв день z месяца.


Информатика (12 баллов) | 107 просмотров
Дан 1 ответ
0 голосов

type

person=record

fam:string;

imya:string;

day:integer;

end;

var

a:array[1..50] of person;

i,n,z:integer;

begin

write('n=');readln(n);

for i:=1 to n do

begin

write('fam-');readln(a[i].fam);

write('imya-');readln(a[i].imya);

write('day-');readln(a[i].day);

end;

write('z-');readln(z);

for i:=1 to n do

if a[i].day=z then writeln (a[i].fam, ' ',a[i].imya);

readln;

end.

 

 

 

(1.5k баллов)