Пожалуйста, помогите написать программу в паскале. Дано число N. Найти сумму его делителей.
Var n,s,i:integer; begin write('N = '); readln(n); if n>1 then s:=1+n else s:=1; for i:=2 to n div 2 do if n mod i = 0 then s:=s+i; writeln('S = ',s); end. Пример: N = 12 S = 28