Напишите программу, которая заменяет в символьной строке все буквы a ** буквы b , буквы A...

0 голосов
259 просмотров

Напишите программу, которая заменяет в символьной строке все буквы a на буквы b , буквы A на буквы B , буквы b на буквы a и буквы B на буквы A .
в c++


Информатика (12 баллов) | 259 просмотров
Дан 1 ответ
0 голосов

#include
#include
using namespace std;

int main()
{
string st;
cout <<"Введите строку; ";<br> getline(cin, st);
for(auto it=st.begin(); it!=st.end(); ++it)
{
switch(*it)
{
case 'a': { *it='b'; break; }
case 'b': { *it='a'; break; }
case 'A': { *it='B'; break; }
case 'B': { *it='A'; break; }
}

}
cout <<"Измененная строка: " <<st << endl;<br>
return 0;

}

Результат работы программы на скриншоте.


image
(1.7k баллов)