ПОМОГИТЕ написать программу в pascal . Дана целочисленная матрица порядка n ** m ....

0 голосов
54 просмотров

ПОМОГИТЕ написать программу в pascal .
Дана целочисленная матрица порядка n на m . Cформировать одномерный массив из элементов кратных на 4 последних P строках . P - число введенное на клавиатуре .


Информатика (54 баллов) | 54 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var m,n:integer;
  Write('Количество строк и столбцов матрицы: ');
  Read(n,m);
  var a:=MatrixRandom(n,m,10,99);
  for var i:=0 to n-1 do begin
    for var j:=0 to m-1 do Print(a[i,j]);
    Writeln
    end;
  var p:=ReadInteger('Введите число Р:');
  var b:array of integer;
  SetLength(b,4*m);
  var k:=0;
  for var i:=n-p to n-1 do
    for var j:=0 to m-1 do
      if a[i,j] mod 4=0 then begin
        b[k]:=a[i,j]; Inc(k)
        end;
  SetLength(b,k);
  b.Print
end.

Тестовое решение:
Количество строк и столбцов матрицы: 6 8
67 70 68 72 38 72 96 38
49 75 24 55 72 63 21 40
72 12 60 22 74 30 13 45
22 45 39 24 35 97 64 31
76 62 15 94 56 28 31 13
41 67 75 37 67 13 25 20
Введите число Р: 4
72 12 60 24 64 76 56 28 20

(142k баллов)
0

неизвестное имя MatrixRandom

0

это ошибка

0

Вы хорошо прочитали название и версию компилятора? Напомню: // PascalABC.NET 3.1, сборка 1218 от 12.04.2016

0

Так что это не ошибка, а Ваша невнимательность

0

Извините

0

Пожалуйста

0

Только вот помечать правильный ответ нарушением не стоит.

0

Такая практика при рецидивах может закончиться баном.