Нужно написать программу в С++ по заданной функции. Основу я написал, но я не знаю, как...

0 голосов
55 просмотров

Нужно написать программу в С++ по заданной функции.
Основу я написал, но я не знаю, как доделать ее до конца, помогите пожалуйста!
Возможно формула arcctang не та, может еще чего...
Номер задания 18, я сделал мини скриншот, чтобы вам было удобнее.
В заранее спасибо !!!


image
image
image

Информатика (131 баллов) | 55 просмотров
0

Чтобы было удобнее - лучше не скриншот, а текст программы вставить.

0

Первый скриншот, это и есть текст программы..

0

Нужна не картинка, а ТЕКСТ

0

#include "stdafx.h"#include #include "math.h"#include #include using namespace std;int _tmain(int argc, _TCHAR* argv[]){ int i, x; float f, y, n, r, z, g; float q; cin >> x >> i; y = 0; r = x; f = 0; z = 1; n = 0; q = x; while(n<=i){ y=z*r/(2*n+1); f=f+y; r=r*x*x; n=n+1; z = z*(-1); /*cout << y << endl;*/} g = (3.1415926 / 2) - f; cout << g << endl; cout << (atan(-x)+(3.1415926/2));system("pause");return 0;}

Дан 1 ответ
0 голосов
Правильный ответ

#include  
#include "math.h"
#include

using namespace std;
int main()
{
float x, e, xn, an, y;
int n;
cin >> x;
e = 0.0001;
n = 0;
xn = x;
an = x;
y = x;
while(abs(an)>e)
{
n = n+1;
xn = -xn*x*x;
an = xn/(2*n+1);
y = y+an;
}
y = 3.14159/2 - y;
cout << y << endl;<br>cout << (3.14159/2-atan(x));<br>
system("pause");
return 0;
}

(194k баллов)
0

А что ты вводил при запуске?

0

0.5