Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в...

0 голосов
40 просмотров

Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел
(массив не использовать).Сделайте три варианта программы,используя операторы While,Repeat ,For.


Информатика (17 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

Var a, b:real;
I:integer;
begin
I:=1;
b:=0;
while I <> 10 do
begin
read (a);
b:=b+a;
I:=I+1;
end;
b:=b/10;
writeln (b);
end.
____________________
var a, b:real;
I:integer;
begin
I:=0;
b:=0;
repeat
read (a);
b:=b+a;
I:=I+1;
until I=10;
b:=b/10;
writeln (b);
end.
_____________________
var a, b:real;
I:integer;
begin
b:=0;
for I:=1 do 10 to
begin
read (a);
b:=b+a;
I:=I+1;
end;
b:=b/10;
writeln (b);
end.

(1.1k баллов)
0

3 задачка чутка неправильна)

0

вот var a, b:real;
c,i:integer;
begin
b:=0;
for c:= 1 to 10 do
begin
read (a);
b:=b+a;
i:=c+1;
end;
b:=b/10;
writeln (b);
end.