Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в...

0 голосов
103 просмотров

Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных
чисел
(массив не использовать).Сделайте три варианта программы,используя операторы While,Repeat ,For.


Информатика (30 баллов) | 103 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

1. While:
var a,i,s:integer;
begin
s:=0;
i:=0;
while i<10 do<br> begin
 i:=i+1;
 write('a = ');
 readln(a);
 s:=s+a;
 end;
writeln('Среднее арифметическое = ',s/10);
end.

2. Repeat
var a,i,s:integer;
begin
s:=0;
i:=0;
repeat
 i:=i+1;
 write('a = ');
 readln(a);
 s:=s+a;
until i=10;
writeln('Среднее арифметическое = ',s/10);
end.

3. For:
var a,i,s:integer;
begin
s:=0;
for i:=1 to 10 do
 begin
 write('a = ');
 readln(a);
 s:=s+a;
 end;
writeln('Среднее арифметическое = ',s/10);
end.

Пример:
a = 4
a = 6
a = 9
a = 7
a = 1
a = 3
a = 6
a = 5
a = 4
a = 8
Среднее арифметическое = 5.3

(194k баллов)
0 голосов

Программа может выглядеть так:

uses Crt;
const n=10;
var  a, i, Sum: integer;
     Sred: real;
begin
ClrScr;
Sum:=0;
i:=1;
While i<=10 do<br> begin
   Write ('a = ');
   ReadLn(a);
   Sum:=Sum+a;
   i:=i+1;
 end;
 Sred:=Sum/n;
 Writeln('Sred = ', Sred:6:2);
 WriteLn;

Sum:=0;
i:=1;
repeat
   Write ('a = ');
   ReadLn(a);
   Sum:=Sum+a;
   i:=i+1;
 until i>n;
 Sred:=Sum/n;
 Writeln('Sred = ', Sred:6:2);
 WriteLn;

Sum:=0;
for i:=1 to n do
  begin
      Write ('a = ');
      ReadLn(a);
      Sum:=Sum+a;
  end;
 Sred:=Sum/n;
 Writeln('Sred = ', Sred:6:2);
 ReadLn;
 end.

(120 баллов)