Составить программу по которой будет найдено значение операции

0 голосов
82 просмотров

Составить программу по которой будет найдено значение операции


image

Информатика (19 баллов) | 82 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var x:=ReadReal('>'); Writeln(x<=0?sqr(x):1/x)<br>end.

Тестовые решения:
> -5.3
28.09

> 2.7
0.37037037037037

(142k баллов)
0

а можно попроще а то мне для 9 класса надо а я мало что понимаю

0

Как раз чем скромнее подготовка, тем проще и короче должна быть программа. Вы же на писали не то, чтобы версию языка, Вы даже вообще не написали, на каком языке программа нужна. А это позволяет давать ответ по своему усмотрению, лишь бы программа работала.

0

ладно спасибо и на этом

0 голосов

Программа, которая вычисляет значение функции:
var x,y:real; 
begin
write('x = '); readln(x);
if x<=0 then y:=x*x else y:=1/x;<br>writeln('y = ',y);
end.

Пример:
x = 5
y = 0.2

(194k баллов)
0

спасибо