Напишите программу, которая заполняет массив из N элементов случайными целыми числами в...

0 голосов
316 просмотров

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет номера двух элементов этого массива, которые расположены ближе всех друг к другу на числовой оси. Эти элементы не обязательно должны быть расположены рядом друг с другом. Если таких пар несколько, нужно вывести номера элементов самой последней из таких найденных пар.

Входные данные
Входная строка содержит три числа: границы диапазона случайных чисел A и B , а также размер массива N . Все числа разделены пробелами. Гарантируется, что 0 < N ≤ 10000 .


Информатика (12 баллов) | 316 просмотров
Дан 1 ответ
0 голосов

Var n,a,b,mi,i,j,ii,jj:int64;    mass:array [1..10000] of int64;beginread(n,a,b);mi:=65345545;for i:=1 to n do begin   mass[i]:=random(a,b);   end;for i:=1 to n do begin   for j:=i+1 to n do begin      if abs(mass[i]-mass[j])<=mi then begin                                      mi:=abs(mass[i]-mass[j]);                                      ii:=i;                                      jj:=j;                                      end;                       end;                 end;writeln(i,j);end.

(1.5k баллов)