(!!! СРОЧНО, МНОГО БАЛЛОВ !!!) Pascal ABC, написать программу: Дан целочисленный...

0 голосов
98 просмотров

(!!! СРОЧНО, МНОГО БАЛЛОВ !!!) Pascal ABC, написать программу: Дан целочисленный одномерный массив, состоящий из n элементов, и натуральные числа k, m (k МЕНЬШЕ m МЕНЬШЕ n). Вычислить среднее арифметическое элементов массива с номерами от k до m включительно.


Информатика (12 баллов) | 98 просмотров
0

Pascal ABC или PascalABC.NET ?

Дан 1 ответ
0 голосов

Const n=100;
var
a: array [1,n] of integer;
 sr:real; k, m, sum, i : integer;
begin
 for i:= 1 to n do a[i]:=ranfom(100);
readln (k);
readln (m);
sum = 0; 
for i:=k to m do
sum:=sum+a[i];
sr := sum/(m - k + 1);
 writeln (sr);
end.


(502 баллов)
0

Это не программа, это какой-то ошметок.

0

не в состоянии объявить переменные и написать writeln (sr)?

0

Правила при регистрации Вы читали и обязались их выполнять. Вот и выполняйте.

0

Параграф 3: "... Размещённый в Сервисе ответ должен содержать решение ВСЕХ проблем содержащихся в вопросе. "

0

const n=100; var a: array [1,n] of integer; sr:real; k, m, sum, i : integer; begin for i:= 1 to n do a[i]:=ranfom(100); readln (k);
readln (m);
sum = 0;
for i:=k to m do
sum:=sum+a[i];
sr := sum/(m - k + 1); writeln (sr); end.

0

Ответ дается в ответе, а не в комментарии. Комментарии при архировании заданий удаляются.