Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение...

0 голосов
104 просмотров

Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.


Информатика (12 баллов) | 104 просмотров
Дан 1 ответ
0 голосов

var n,count:integer;
begin
  repeat
     readln(n);
     if(n<>999) then inc(count);
  until(n=999);
  writeln(count);
  readln;
end.

(170 баллов)