Написать программу ** языке C++. Перевести с помощью рекурсивной функции conv (n, p) за-...

0 голосов
41 просмотров

Написать программу на языке C++.
Перевести с помощью рекурсивной функции conv (n, p) за-
данное натуральное число n в p-ичную систему счисления
(2 ≤ р ≤ 9).


Информатика (302 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

void conv(int n, int p) {
if(n/p!=0){
        conv(n/p,p);
    }
    cout << n%p;<br>}
 int main()
{
    int n, p;
    string m;
    cout << "Введите n:", cin >> n, cout << "\n";<br>    cout << "Введите p:", cin >> p, cout << "\n";<br>    conv(n,p);
    return 0;
}

Пример:
Введите n: 511
Введите p: 8
777

(194k баллов)