Задача по информатике. Pascal или Delphi с подробным решением и объяснениями! Банкомат В...

0 голосов
89 просмотров

Задача по информатике. Pascal или Delphi с подробным решением и объяснениями!

Банкомат
В некотором государстве в обращении находятся банкноты определенных номиналов. Национальный банк хочет, чтобы банкомат выдавал любую запрошенную сумму при помощи минимального числа банкнот, считая, что запас банкнот каж дого номинала неограничен. Помогите Национальному банку решить эту задачу.

Входные данные
Первая строка входных данных содержит натуральное число N не превосходящее 100 — количество номиналов банкнот в обращении. Вторая строка входных данных содержит N различных натуральных чисел x1, x2, ..., xN, не превосходящих 106 — номиналы банкнот. Третья строчка содержит натуральное число S, не превосходящее 106 —сумму, которую
необходимо выдать.

Выходные данные
Программа должна найти представление числа S виде суммы слагаемых из множества xi, содержащее минимальное число слагаемых и вывести это представление на экран (в виде последовательности чисел, разделенных пробелами). Если таких представлений существует несколько, то программа должна вывести любое (одно) из них. Если такое представление не существует, то программа должна вывести строку No solution.


Примеры
входные данные
5
1 3 7 12 32
40
выходные данные
32 7 1


Информатика (592 баллов) | 89 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var v:array [0..100000] of integer;    a:array [0..100,0..100000] of integer;    m,p,k,w:integer;
procedure step(z,ma:integer);beginif z>0 then       if a[z,ma]<>a[z-1,ma] then                             if a[z-1,ma]
beginread(k);for p:=1 to k do begin   read(v[p]);   end;read(w);for p:=1 to k do begin   for m:=1 to w do begin      if m-v[p]>=0 then a[p,m]:=(max(a[p-1,m-v[p]]+v[p],a[p-1,m]))                   else a[p,m]:=a[p-1,m];      end;      end;if a[k,w]=w then step(k,w)            else writeln('No solution');end.

(1.5k баллов)
0

step(k,w) ('No solution') что это такое? Ни разу не использовали такое

0

var v:array [0..100000] of integer; a:array [0..100,0..100000] of integer; m,p,k,w:integer;

0

Заказываем переменные

0

procedure step(z,ma:integer);beginif z>0 then if a[z,ma]<>a[z-1,ma] then if a[z-1,ma]<a[z-1,ma-v[z]]+v[z] then begin step(z-1,ma-v[z]); write(v[z],' '); end else step(z-1,ma) else step(z-1,ma); end;

0

Процедура степ, к которой я и обращаюсь, в Step(k,w)/

0

То есть при выполнении программы со степа я перехожу к самой процедуре и она выполняется в программе. В данном случае эта программа восстанавливает ответ

0

Если такое представление не существует, то программа должна вывести строку No solution.
Вот я и пишу No solution, когда представлений не существует.

0

спс, буду пытаться разобраться. А другие есть способы решения, без процедуры?

0

да. Но я такое чудо составить сам не смогу. Это называется задача о рюкзаке. Попробуй поискать в интернете. Банкомат - это одна из самых сложных задач этого раздела. Есть подробное обьяснение на http://informatics.mccme.ru/course/view.php?id=9. Раздел "Задача о рюкзаке."

0

Задачу про рюкзак решали, надо будет глянуть