Доброго времени суток! Пожалуйста, помогите написать программу ** С++ для решения задачи....

0 голосов
59 просмотров

Доброго времени суток! Пожалуйста, помогите написать программу на С++ для решения задачи.

Дано целое число n. Выведите следующее за ним четное число. При решении этой задачи нельзя использовать условную инструкцию if и циклы.

Входные данные
Вводится целое число.

Выходные данные
Выведите ответ на задачу.


Информатика (69 баллов) | 59 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

int main()
{
    int n, m;
    cout << "n = ", cin >> n, cout << "\n";<br>    m = n + 1 + (n+1)%2;
    cout << "m = " << m;<br>    return 0;
}

Пример:
n = 17
m = 18

(194k баллов)