Ниже записана программа. Получив ** вход число x, эта программа печатает два числа....

0 голосов
48 просмотров

Ниже записана программа. Получив на вход число x, эта программа печатает два числа. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:= L + 1;
if x mod 2 = 0 then
M:= M + x mod 10;
x:= x div 10;
end;
writeln(L); write(M);
end.


Информатика (46 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

Ответ:998
/////////////////////

(1.7k баллов)