написать программу ** Паскале: "если введенное целое число является трехзначным, то...

0 голосов
31 просмотров

написать программу на Паскале:

"если введенное целое число является трехзначным, то удалить из него среднюю цифру; если число двухзначное, то удвоить крайние цифры; иначе – выдать сообщение «Ошибка ввода»."


Информатика (34 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

program z1;
uses crt;
var n:integer;
begin
writeln(''вв число');
readln(n);
if n>999 then writeln('ошибка ввода') else
if n>100 then writeln((n div 100)*10+n mod 10 ) else
writeln((((n div 10)*2)*10)+((n mod 10)*2));
end.

(102 баллов)