Паскаль. Написать программу, которая выводит на экран количество чисел Х в массиве. В массиве N элементов, числа целые. Х задаётся. Помогите)))
Var a:array[1..1000] of longint; i,k,n,s:integer; begin s:=0; randomize; readln(n); for i:=1 to n do begin a[i]:=random(100); write(a[i],' '); end; writeln; readln(k); for i:=1 to n do if a[i]=k then inc(s); write(s); end.