Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в...

0 голосов
52 просмотров

Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы,используя операторы While,Repeat ,For.


Информатика (1.2k баллов) | 52 просмотров
0

не интересно

0

Ну пожалуйста, можете тогда проверить хотя бы, просто я не уверен в правильности.

0

проверить могу

0

Давайте, я в лс к вам напишу.

0

ок

0

хотя лучше сюда код бросай

Дан 1 ответ
0 голосов
Правильный ответ

//1
const
    n = 10;

var
    a, i, sum: integer;

begin
    sum := 0;
    i := 1;
    repeat
        Write('Введите число = ');
        Readln(a);
        sum := sum + a;
        i := i + 1;
    until i > n;
    
    Writeln('Среднее арифметическое = ', sum / n);
end.
//2
const
    n = 10;

var
    a, sum, i: integer;

begin
    sum := 0;
    i := 1;
    while i <= n do<br>    begin
        Write('Введите число = ');
        Readln(a);
        sum := sum + a;
        i := i + 1;
    end;
    Writeln('Среднее арифметическое = ', sum / n);
end.
//3
const
    n = 10;

var
    a, i, sum: integer;

begin
    sum := 0;
    for i := 1 To n Do
    begin
        Write('Введите число = ');
        Readln(a);
        Sum := Sum + a;
    end;
    Writeln('Среднее арифметическое = ', sum / n);
end.
(53.1k баллов)