Написать программу, которая запрашивает массив из N элементов, а затем делает все...

0 голосов
62 просмотров

Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент. Протестировать программу на массивах размерностью 5 и 10 элементов


Информатика (103 баллов) | 62 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var i,N:integer;

       Min:real;

      mas:array[0..100]of real;

beegin

write('введите N');

read(N);

 

{for i:=1 to N do begin

mas[i]:=random(50);write(mas[i],'  ');end;

 

или
for i:=1 to N do

read(mas[i]);

for i:=1 to N do

write(mas[i],'  ');}

 

min:=mas[0];

for i:=0 to N do 

if min

 

writeln;

for i:=1 to N do begin

mas[i]:=mas[i]/min;write(mas[i]);end;

 

 

(468 баллов)