Написать программу, которая выводит таблицу квадратов первых десяти целых положительных...

0 голосов
387 просмотров

Написать программу, которая выводит таблицу квадратов первых десяти целых положительных чисел (естественно, квадраты должны считаться В ЦИКЛЕ!). Ниже представлен вид экрана во время работы программы, который вам нужно реализовать:

Таблица квадратов
-----------------------------
Число Квадрат
-----------------------------
1 1
2 4
и т.д.


Информатика (34 баллов) | 387 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

program kvadrat;
var i, n: integer;
begin
  writeln ('Таблица квадратов');
  writeln ('-----------------');
  writeln (' Число  Квадрат');
  writeln ('-----------------');
  i:= 1;
  n:= 10;
  for i:=1 to n do
  begin
    writeln ('  ',i,'   ', sqr(i));
  end;
  writeln ('-----------------');
end.

(52.6k баллов)
0 голосов

program v1;

var a,n: real;

begin

a:= 1;

n:= 10;

while a <= n do begin</p>

                             writeln (a, sqr(a));

                             a:= a+1;

                             end;

end.

 

(155 баллов)