Составить программу обработки массива F(21). Каждый третий элемент массива F возвести в...

0 голосов
38 просмотров

Составить программу обработки массива F(21). Каждый третий элемент массива F возвести в квадрат, если элемент отрицательный. Эти значения напечатать. Pascalabc( 9 класс)


Информатика (50 баллов) | 38 просмотров
0

ща все будет

Дан 1 ответ
0 голосов

Var
  i: integer;
  f: array[1..21] of integer;
begin
  randomize;
  for i := 1 to 12 do 
  begin
    f[i]:=random(21)-10;
    if (i mod 3 = 0)and(f[i]<0) then f[i]:=sqr(f[i]);<br>    writeln(f[i]);
  end;
end.

(516 баллов)