Помогите написать программу в Pascal используя циклы. а)S квадратов чисел от 1 до n+1....

0 голосов
33 просмотров

Помогите написать программу в Pascal используя циклы.
а)S квадратов чисел от 1 до n+1.
б)P кубов чисел от 1 до n-5.
в)частное от деления S на P.
Записать это все в одну программу.


Информатика (15 баллов) | 33 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// var n,s,p,i:integer; - для значений n < 18
var n,s,i:integer; p:real;
begin
write('n = '); readln(n);
s:=0;
for i:=1 to n+1 do s:=s+i*i;
writeln('s = ',s);
p:=1;
for i:=1 to n-5 do p:=p*i*i*i;
writeln('p = ',p);
writeln('s/p = ',s,'/',p,' = ',s/p);
end.

Пример:
n = 10
s = 506
p = 1728000
s/p = 506/1728000 = 0.000292824074074074

(194k баллов)
0

Например с числом 20, показывает что S/P=бесконечность

0

Значение p получается очень большое. Можно первую строку написать так: var n,s,i:integer; p:real;

0

а все

0

понял