напишите программу, которая выводит ** экран значение n! включая следующую функцию...

0 голосов
55 просмотров

напишите программу, которая выводит на экран значение n! включая следующую функцию function factorial (n:integer):integer; var p,i:integer; begin p:=1; for i:=1 to n do p:=p*i; factorial:=p; end;


Информатика (16 баллов) | 55 просмотров
Дан 1 ответ
0 голосов

Program p1;

uses crt;

function factorial (n:integer):integer; var p,i:integer; begin p:=1; for i:=1 to n do p:=p*i; factorial:=p; end;

var n:integer;

begin

 Write('Введите число, n=');

 Readln(n);

 Writeln('Факториал  = ',factorial(n));

end.

(696 баллов)