Ниже записана программа. Получив ** вход число x, эта программа печатает два числа....

0 голосов
96 просмотров

Ниже записана программа. Получив на вход число x, эта программа печатает два числа. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 4.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=9;
while x > 5 do begin
L:= L + 1;
if M > (x mod 10) then M:= x mod 10;
x:= x div 10;
end;
writeln(L); write(M);
end.


Информатика (480 баллов) | 96 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Решение в файле 5994

(3.4k баллов)