Написать программу, в которой пользователь вводит несколько чисел, программа выводит...

0 голосов
86 просмотров

Написать программу, в которой пользователь вводит несколько чисел, программа выводит количество положительных чисел.


Информатика (20 баллов) | 86 просмотров
Дан 1 ответ
0 голосов
program cycle_for;
var i,kn : byte; x:real;
begin
   kn:=0;
     for i:=1 to 10 do
       begin
          writeln('Введите ',i,' число: ');
          readln(x);
       if x>0 then kn:=kn+1 
{увеличиваем кол-во на 1}
end;
   writeln('Вы ввели ',kn,' положительных чисел.');
readln
end.

(184 баллов)