Напишите программу для решения следующей задачи. ** соревнованиях по бегу ** 5000 метров...

0 голосов
393 просмотров

Напишите программу для решения следующей задачи.

На соревнованиях по бегу на 5000 метров для выхода в финал необходимо показать время не более 18 минут 30 секунд.

Сколько спортсменов по результатам соревнований вышли в финал?

Программа получает на вход количество спортсменов, принимавших участие в соревнованиях (1 ≤ N ≤ 100), затем для каждого спортсмена вводится два числа: минуты и секунды – время, показанное на дистанции.


Информатика (154 баллов) | 393 просмотров
Дан 1 ответ
0 голосов

Var n,m,s,i,kol:int64;
begin
read(n);
for i:=1 to n do begin
   read(m,s);
   if (m<18) then inc(kol);<br>   if (m=18) and (s<=30) then inc(kol);<br>   end;
writeln(kol);
end.

(1.5k баллов)