Используя класс string написать программу ** языке с++ и блок-схему по которой написана...

0 голосов
30 просмотров

Используя класс string написать программу на языке с++ и блок-схему по которой написана программа
помогите, пожалуйста!


image

Информатика (30 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

#include
#include

void main()
 {
 setlocale(0, "");
std::string str="Жыли,животное,шыло,шиворот";
for (int i = 0;i < str.length();++i)
{
 if (((str[i] == 'ш') || (str[i] == 'ж') || (str[i] == 'Ж') || (str[i] == 'Ш'))&&(str[i + 1] == 'ы')))    std::cout << "Ошибка в позиции " << i + 2 << std::endl;<br> }
 system("pause");
}





image
(1.8k баллов)