Помогите написать программу в с++ Составить программу определения значений указанных ниже...

0 голосов
37 просмотров

Помогите написать программу в с++ Составить программу определения значений указанных ниже линейного массива.Выполнить программу для длины массива N=8 Сумма обратных величин ненулевых элементов массива


Информатика (105 баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;
const int N = 8; //длина массива
double s = 0; //начальное значение суммы
double mas[N]; //объявляем статический массив длины N
int main()
{
    //вводим элементы массива
    for(int i = 0; i < N; ++i)
    {
        cin >> mas[i];
    }
    //пробегаемся по элементам массива
    for(int i = 0; i < N; ++i)
    {
        if(mas[i] != 0.0) //если элемент массива не равен 0
            s += 1. / mas[i]; //прибавляем значение обратного элемента к итоговой сумме
    }
    cout << s; //вывод суммы на экран<br>    return 0;
}

(16.7k баллов)