Написать программу с помощью цикла for. Из чисел от 10 до 99 вывести те, сумма которых...

0 голосов
44 просмотров

Написать программу с помощью цикла for. Из чисел от 10 до 99 вывести те, сумма которых равна N. N-вводится с клавиатуры. Паскаль.


Информатика (27 баллов) | 44 просмотров
0

может быть сумма цифр?

Дан 1 ответ
0 голосов
Правильный ответ

Var
    i, n: integer;

begin
    readln(n);
    
    for i := 10 to 99 do
        if (i mod 10 + i div 10 = n) then
            writeln(i);
end.

(53.1k баллов)