написать программу нахождения большего и меньшего из 3 чисел помогите...

0 голосов
165 просмотров

написать программу нахождения большего и меньшего из 3 чисел

помогите пожалуйстаааааааааа((((


Информатика (122 баллов) | 165 просмотров
Дано ответов: 2
0 голосов

var a,b,c:integer;
begin
readln(a,b,c);
if (a>b) and (a>c) and (b>c) then writeln('c=',c,'a=',a) else
if (b>a) and (b>c) and (a>c) then writeln('c=',c,a,'b=',b) else
if (c>a) and (c>b) and (b>a) then writeln('a=',a,'c=',c) else
if (a>b) and (a>c) and (c>b) then writeln('b=',b,'a=',a) else
if (b>a) and (b>c) and (c>a) then writeln('a=',a,'b=',b) else
if (c>a) and (c>b) and (a>b) then writeln('b=',b,'c=',c) else
readln;
end

(1.6k баллов)
0 голосов

var 

  a, b, c: real;

 

begin

  writeln('Введите 3 любых числа');

  readln(a, b, c);

  if (a < b) and (a < c) then writeln(a, ' - наименьшее число');

  if (b < a) and (b < c) then writeln(b, ' - наименьшее число');

  if (c < a) and (c < b) then writeln(c, ' - наименьшее число');

  if (a > b) and (a > c) then writeln(a, ' - наибольшее число');

  if (b > a) and (b > c) then writeln(b, ' - наибольшее число');

  if (c > a) and (c > b) then writeln(c, ' - наибольшее число');

  readln; //Убрать если среда разработки не Turbo Pascal

end.

(2.1k баллов)