Помогите,всё что сможете!5) С помощью repeat напишите программу, которая требует у вас...

0 голосов
48 просмотров

Помогите,всё что сможете!5) С помощью repeat напишите программу, которая требует у вас пароль, например 111. Если пароль правильный, то заполняет все строки экрана сообщением «Молодец». Если после пятой попытки пароль все равно неверен, выходит из программы. (2 балла)

21) Составьте программу вычисления степени числа A с натуральным показателем N. Записать варианты программы со всеми видами циклов: while, repeat, for. (3 балла)

27) Составьте программу, которая выводит полную запись десятичного числа 42*4*, в которой пропущены две цифры (обозначены *), если известно, что данное число кратно 72. (4 балла)

1) Найти все двузначные числа, сумма цифр которых не меняется при умножении числа на 2,3,4,5,6,7,8,9.

2) Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

3) Найти все трехзначные числа, средняя цифра которых равна сумме первой и второй цифр.

4) Найти все трехзначные числа, которые можно представить разностью между квадратом числа, образованного первыми двумя цифрами и квадратом третьей цифры.

5) Найти все двузначные числа, сумма квадратов цифр которых делится на 17.

6) Найти все трехзначные числа, представимые в виде сумм факториалов своих цифр.

7) Найти двузначное число, обладающее тем свойством, что куб суммы его цифр равен квадрату самого числа.

8) Найти двузначное число, равное утроенному произведению его цифр.

9) В каких двузначных числах удвоенная сумма цифр равна их произведению?

10) Можно ли заданное натуральное число М представить в виде суммы квадратов двух натуральных чисел? Написать программу решения этой задачи.


Информатика (19 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

Repeat clrscr; WriteLn ('Введите пароль: '); ReadLn (pas); until pas = '1234';

(14 баллов)
0

На мой взгляд, да и не только, пароль не должен светиться на экране.
Я бы пошел таким путем:
Код:

Uses Crt;
...
function Password(): string;
var ch: char;
pas : string;
begin
pas := '';
repeat
if KeyPressed() then begin
ch := ReadKey();
if ch = #0 then
ch := ReadKey();
if Ord(ch) = 13 then
Break;
write('*');
pas := pas + ch;
end;
until false;
Password := pas;
end;

и затем вызывал эту функцию:
Код:

pas := Password();

и выполнял сравнение, см. код выше
вместо
Код:

readln(pas);

Как-то так ...