Написать программу ** Си (метод ньютона) В соответствии с этим методом каждое следующее...

0 голосов
45 просмотров

Написать программу на Си (метод ньютона)
В соответствии с этим методом каждое следующее приближение к корню ищется по формуле: x_{k} = x_{k-1} - \frac{f( x_{k-1})}{ f^{'} ( x_{k-1})}
Итерационный процесс уточнения корня заканчивается при достижении условия: | x_{k}- x_{k-1}| < ε где ε – заданная точность.

уравнение: 3х-4ln-5=0
отрезок содержащий корень [2;4]
точность 10^(-4)


Информатика | 45 просмотров
0

А что за функция f(x)?

0

и еще вопрос, почему у ln нет аргумента? :)

Дан 1 ответ
0 голосов

Как-то так, прилагаю и сам сpp-файл :)

#include#include
const double EPS = 1e-4;
double f(double x){return 3*x - 4 * log(x) - 5;}
double fp(double x){return 3 - 4 * (1/x);}
int main(){double prev = 2, cur; //prev - x (k-1)ое, cur - x k-тоеcur = prev - f(prev)/fp(prev);while(abs(cur - prev) > EPS){ prev = cur; cur = cur - f(cur)/fp(cur);}
printf("%lf\n", cur);return 0;}

(2.0k баллов)
0

будут вопросы - спрашивайте :)

0

какой компилятор?

0

хотяя, ошибку-то линкер выдает...

0

На чем ты запускаешь ее? Я на VS2010 работаю) там все работает, могу экзешник кинуть :D

0

а нет, не могу :)