Нужно сделать подпрограмму. Помогите не умею я подпрограммы писать! 9 класс, Делфи...

0 голосов
68 просмотров

Нужно сделать подпрограмму. Помогите не умею я подпрограммы писать! 9 класс, Делфи

Сделать подпрограмму, которая вводит с клавиатуры 3 числа, находит найбольшее и выводит на экран.


Информатика (436 баллов) | 68 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
var a,b,c:integer;
begin read(a,b,c);
   if (a > b) and (a > c) then

        write(a)
   else
       if (b > a) and (b > c) then

        write(b)
   else
        write(c);

end.
В делфи добавишь на форму Эдиты(4 штуки) и одну кнопку. В трех Эдитах будешь вводить свои значения, а в четвертом выведешь ответ и все это при клике на кнопку:
Procedure btn1Click;
var a, b, c, max: integer; 
begin 
a:= StrToInt(edt1.Text); // где edt1,2,3 - имена полей для ввода(Эдиты)
b:= StrToInt(edt2.Text);
c:= StrToInt(edt2.Text);
   if (a > b) and (a > c) then
 
        max:= a; 
   else 
       if (b > a) and (b > c) then
 
        max:= b;
   else 
        max:= c;
edt4.Text:= 'Максимальное число' + max;
//или ShowMessage(Максимальное число' + max); 
end.
(985 баллов)
0

спасибо. Немогли бы вы помочь еще с этим? Написать программу которая находит сумму елементов, которые польше числа введенного с клавиатуры. вывести масив и сумму на экран. масив вводиться с клавиатуры.

0

Program sum;
Var i,s,n:integer;
a:array[1..10] of integer;
Begin
write('Введите элемент с которым сравнивать= ');readln(n);
s:=0;
For i:=1 to 10 do begin
write('Введите ',i,'-й элемент ');readln(A[i]);
end;
For i:=1 to 10 do
if A[i]>n then begin write(A[i]:4);s:=s+A[i];End;
Writeln;
Writeln('Сумма= ',s);
readln;
End.

0

В делфи массив можно вывести вот так:

0

memo1.Lines.Add(IntToStr(mas[i]));

0

Точнее вот так

0

for i:= 1 to 6 do
memo1.Lines.Add(IntToStr(mas[i]));

0

вместо 6 подставляешь свои 10