Написать программу в Паскале.

0 голосов
47 просмотров

Написать программу в Паскале.


image

Информатика (16 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Var a,k:int64;
begin
read(a);
while a>=7 do begin
if (a mod 7)=3 then inc(k);
a:=a div 7;
end;
if a=7 then inc(k);
write(k);
end.

(1.5k баллов)