Написать программу ** паскале. Вычислить значение Y по одной из формул. Y= X+a, если X<10...

0 голосов
59 просмотров

Написать программу на паскале.
Вычислить значение Y по одной из формул.
Y= X+a, если X<10<br> X+b, если 10\leqX\leq23
X+a^{2}, если X>23


Информатика (30 баллов) | 59 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    x, a, b: real;

begin
    readln(x, a, b);
    
    if x < 10 then
        x := x + a
    else if x > 23 then
        x := x + a * a
    else
        x := x + b;
    writeln(x);
end.

(53.1k баллов)