Помогите написать программу в С++ n=min(x+y,y-z)/max(x,y)

0 голосов
103 просмотров

Помогите написать программу в С++
n=min(x+y,y-z)/max(x,y)


Информатика (105 баллов) | 103 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

int main()
{
    double x, y, z, min, max, n;
    cout << "Введите x:", cin >> x, cout << "\n";<br>    cout << "Введите y:", cin >> y, cout << "\n";<br>    cout << "Введите z:", cin >> z, cout << "\n";<br>    if (x+y    else min = y-z;
    if (x>y) max = x; 
else max = y;
n = min/max;
    cout << "n = " << n;<br>    return 0;
}

Пример:
Введите x: 5
Введите y: 8
Введите z: 3
n = 0.625

(194k баллов)
0

почему то выбивает ошибку..(( using namespare std; - в этой строчке

0

спасибо.все разобралась дальше сама)